Cannot control wrapping for COMMENT clause

I'm using DBE plugin on IntelliJ IDEA 2016.1 (with MySQL dialect).

When I write the COMMENT clauses in CREATE statement, auto-formatter always makes they wrapped. 

CREATE TABLE `example` (
`id` INT UNSIGNED NOT NULL AUTO_INCREMENT
COMMENT 'ID',
`name` VARCHAR(100) NOT NULL
COMMENT 'The Name',
PRIMARY KEY (`id`)
)
COMMENT = 'This is an example of unwilling wraps';
CREATE TABLE `example` (
`id` INT UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'ID',
`name` VARCHAR(100) NOT NULL COMMENT 'The Name',
PRIMARY KEY (`id`)
) COMMENT = 'This is an example just expected';

Can I control these behavior?

Thank you.

 

2 comments
Comment actions Permalink

Hi,

Try Other clauses option in File | Settings | Editor | Code Style | SQL -> New line before settings.

0
Comment actions Permalink

Hi Andrey.

Oh, I overlooked it...
It solves my problem completely. XD

Thanks!

0

Please sign in to leave a comment.