Error Stack trace when running FlexUnit

Mezer_08-20_16-30-48.jpg
Hi, regarding the image above.  I created a test which has an error in it.  However when the test runs, the output screen doesn't actually tell me where the error is.  How do I fix this?
I'm using FlexSDK 4.1, and the latest stable version of FlexUnit 4.1
I tried putting a breakpoint but that didn't seem to work either.

Thanks.

7 comments
Comment actions Permalink

May be more info if you select parent node in the test result tree? Or may be Flash Player gives popup with details?

Error 1009 stands for "Cannot access a property or method of a null object reference." What kind of test is this? Any special initialization? Try to catch the execution with a breakpoint at some early stage, like setUp() method.


I'm ready to evaluate the issue if you can attach a sample project.
0
Comment actions Permalink

There was no popup, and there clicking higher on the tree doesn't give me any more information either.

I purposefully made a failing test by passing in null to the constructor of a class that required another class as a constructor parameter.  I'm testing out inteliJ and wanted to see how it worked.

Is there a configuration or something that I need to set up to see stack traces when running flexunit tests?

Here is a picture of my module dependencies.


Mezer_08-20_17-01-29.jpg


I will try creating a new blank project and see if I can send that to you, or if the problem is not reproduced.  Thanks.

0
Comment actions Permalink

Here is a project that has the same result



Attachment(s):
randomTest.zip
0
Comment actions Permalink

Hm, I get detailed test results.
Untitled.png

0
Comment actions Permalink

One idea: make sure that you have debugger version of the Flash Player where tests are executed.

0
Comment actions Permalink

Hint: you can select which Flash Player or browser to use for test execution in the run configuration: Run | Edit configurations...

0
Comment actions Permalink

Thank you.

Apparently the "system default application" is not the debug version of the flashplayer :)

0

Please sign in to leave a comment.