How to include files in the output directory relative to the compiled swf when simulating?

I know how to include files in the packaging phase of an iOS or Android app, but how can I make those files available and relative to a .swf when simulating?

Thanks for your time!

Comment actions Permalink

You need to keep resource files within source roots. These files will be copied to the output folder (preserving relative path) according to the corresponding option at Project Structure | Modules | [your module] | [your build configuration subnode] | Compiler Options tab. By default it is 'copy all files except *.as and *.mxml.
Probbly you'd like to vote for

Comment actions Permalink

Thank you Alexander,
that's what I did: and all my "assets" from the src/ folder are copied to the out/production/myProject/ path where  the .apk is located.
But they had not been included in the .apk package.

But thanks to your answer in the other thread (, where you said:
"Files to package are also configured at 'Android' tab."
I had checked that window again and finally found the option I was looking for so desperately. I somehow missed that "Files and folders to package" settings on that page! That was exactly what I was looking for...
And adter including my asset's folder there, all looks perfect now.

Sorry for my "blindness"; but there are so many paths and options; and although I finally got my arms around IDEA more or less, there still are some secrets I have to find out.
But I already feel very comfortably now and like the IDE very much.

Thanks for your help!

How can I mark my question "answered"?

Comment actions Permalink

I'm glad that your problem is solved. Note that your original question was not correct. You asked about 'how to include files in the output directory, but in fact you were looking for 'How to include files in the APK package'.

Comment actions Permalink

Yes, you are right! I'll more carefully formulate my question next time...
Something I learned in the discussions with my son (he's the IT professional; not I) also :D


Please sign in to leave a comment.