Ubuntu eats my shortcuts: Ctrl-Alt-Shift-Up/Down

I am about to finish a big refactoring and want to clean up my changes before commit.

There are keyboard shortcuts to navigate to the next/previous change in a file: Ctrl-Alt-Shift-Down/Up
However IDEA never receives those keystrokes.

I managed to get rid of all other conflicting shortcuts in Ubuntu, but cannot figure out who eats these particular three-modifiers-combinations :-(

Ubuntu 12.0.4 with Cinnamon 1.8.8

7 comments
Comment actions Permalink

System > Keyboard > Shortcuts > Navigation > Move window one workspace to the <direction>
Change or disable them. As for me, I never used those operations so I disabled them.

Regards

3
Comment actions Permalink

Thanks for the answer.
I already disabled all shortcuts there, so _all_ items in there only show "unassigned" and no other item in any of the other category has such a mapping:
shortcuts.png

When I run "xev" in the terminal it displays
   KeymapNotify event, serial 32, synthetic NO, window 0x0,
when I press ctrl-alt-shift-down.
For all regular combinations it shows proper Keypress events.

1
Comment actions Permalink

How did you solve this problem? I have exactly the same issues

0
Comment actions Permalink

In the end I switched to Kubuntu 😊

0
Comment actions Permalink

Initially I gave up and assigned a different keyboard shortcut to move to next/previous change. I just revisited this approach since I wanted to use the default shortcuts. I ended up having a to disable the following in order to get it working as expected 

2
Comment actions Permalink

In Ubuntu Unity 8 (based on Gnome Shell, Ubuntu 18.04 or newer), by default the `Shift+Meta+Page Up` is used for "move window one workspace up", but I think there is also an invisible binding for `Ctrl+Alt+Shift+Up` as well. You can get rid of this invisible binding, by opening the Settings / Devices / Keyboard and manually setting the "Move window one workspace up" to Shift+Meta+Page Up. The setting key combination will show in bold, and now the `Ctrl+Alt+Shift+Up` should no longer be captured by Unity.

1

Please sign in to leave a comment.