Compiler internal error. Process terminated with exit code 138 under Mac OS X Lion 10.7.5

Hi everybody!

I have a problem with compiling my project on Mac after a recent OS update.
I'm using IDEA 10.5.4 and get the compiler internal error while trying to make the project using javac compiler. The JDK version is 1.6.0_51. The OS is X Lion 10.7.5.

I've tried to use Javac in-process compiler and did not get the internal error, but almost immediately after the application start I get an OutOfMemoryError: PermGen space. I've increased the MaxPermGen up to 128m and the error dissapeared but the workaround doesn't statisfy me. I have to use javac.

I've also tried to compile my application with 1.7 and 1.5 JDKs but still got the same internal error.

Could you please help me to solve the problem with internal error.

Thank you in advance!

1 comment

Hi Mikhail,

First, please check the <idea-system>/log/idea.log file uf it has some additional information about the internal error. If there is nothing relevant in the log, please modify idea-home/bin/log.xml
and add the following category there:

  <category name="#com.intellij.compiler">
    <priority value="DEBUG"/>
    <appender-ref ref="FILE"/>
  </category>


Close IDEA, delete idea.log and restart IDEA again. Then try to compile and get the internal error. The idea.log should contain all lines that were retrieved from Javac's standard outputs.

Hope this helps with diagnostics.

Eugene.
0

Please sign in to leave a comment.