Change properties file encoding disabled

Answered

Hi Everyone,

I've got a problem like this. I manage my properties files using different encoding under one folder.

But for these properties files, I cannot change file encoding either from the status bar or the File

drop down menu, since they are all greyed out. However, I find no problem changing encoding files

of java source files. Thx.

here's what I got:

2013-07-25 18_00_19-.png
9 comments
Comment actions Permalink

Hello.

If you'd like to change encoding for all properties files then Settings dialog / File Encodings page // Properties Files section / "Default encoding for ..." can help.

Regards,
Alexander.

-1
Comment actions Permalink

Thanks for response.
That does not help changing encoding under folder either。
What's working for me so far is changing default encoding for all properties files right at the bottom of
Setting - File Encodings. Still want to know why others do not work correctly..

3
Comment actions Permalink

Actually I want my encoding detector plugin works as well for all filetypes....Event on vim, I can use auto encoding detect for all files, but it's not working on your IDEA, it's sad. Some of my workmates use GBK and some of my workmates use utf-8....

0
Comment actions Permalink

@Happy Zengda,

What encoding plugin you are using? 

0
Comment actions Permalink

@Happy Zengda

Please contact plugin developer (1329750315@qq.com) to know why this plugin does not detect filetypes you are working with

0
Comment actions Permalink

What @Alexander Chernikov said is not working.  Settings dialog / File Encodings page // Properties Files section / "Default encoding for ..."  is used to configures encoding for a file not converts a file into a specific encoding. 

0
Comment actions Permalink

And I just wonder why the file encoding conversion option is almost only available for Java file. When opening files like properties files, HTML files, the file encoding option are all greyed out. Is there any difference between Java files and properties files in the file encoding conversion job?

0
Comment actions Permalink

>  is used to configures encoding for a file not converts a file into a specific encoding. 

IntelliJ IDEA does not change the encoding if "Transparent native-to-ascii conversion" option is set:

https://www.jetbrains.com/help/idea/properties-files.html#encoding

> file encoding conversion option is almost only available for Java file.

Do you tell about "File Encoding" button at the right bottom: 

https://i.imgur.com/nRXH8ic.png

It is grayed out in case the encoding is specified in the file itself. See https://blog.jetbrains.com/idea/2013/03/use-the-utf-8-luke-file-encodings-in-intellij-idea/

0

Please sign in to leave a comment.