Run/Debug configuration Make Before Launch

In a run/debug configuration,  if you select  the  "Make" option  under  "before launch"  is there any way to

see a log or a trace of what exactly the make will attempt to build. Is there any additional configuration controlling the make?

We are trying to debug an issue only seen since upgrading to IntelliJ IDEA 12.

If we run a particular junit run/debug config  via IDEA 10 or 11,  the make is performing a necessry step of copying

some xml files from a META-INF  folder  into the output directory.

but when we run the same  junit run/debug config  (on the same machine)  via  IDEA 12, for some reason this step is

not getting performed by the make?!   If we can get a trace or log of the make we might be able to figure out what

is going on.

Thanks

Mike

1 comment

Mike001 wrote:

is there any way to see a log or a trace of what exactly the make will attempt to build.

Not that I'm aware of. But I do get surprised every now and then about something I did not know existed in IDEA. You can go into the maintenance registry (Ctrl + Alt +Shift + /) and turn on the ide.debugMode setting. (I can't remember if a restart is required) I'm not sure if that adds more verbosity to the logs for the compiler.

Mike001 wrote:

Is there any additional configuration controlling the make?

All the settings are under File > Settings > [Project Settings] > Compiler In particular, given the situation you describe, you'll want to check the setting of the Resource patterns on the top of the Compiler settings dialog. Make sure xml files are not getting excluded which would prevent them from being copied. That setting changed at some point (night have been in 12). You use to declare files to copy; now you declare files to exclude. Take a look at the help dialog for that settings page.

Mike001 wrote:

We are trying to debug an issue only seen since upgrading to IntelliJ IDEA 12.

The compiler (and thus the make process) was revamped in IDEA 12. Take a look at the blog entry IntelliJ IDEA 12 Compiler. Twice as Fast for more details. So its possible one of the new settings (and its default) is causing the issue.

0

Please sign in to leave a comment.