idea.sh crash on ubuntu feisty (SIGSEGV) - help needed

When trying to execute idea.sh (build 7343) using java sun-1.5.0.11 (ubuntu feisty) I get this:
"java.lang.UnsupportedClassVersionError: Bad version number in .class file"

but when using java 1.6.0_03-b05 I get:

#

  1. An unexpected error has been detected by Java Runtime Environment:

#

  1. SIGSEGV (0xb) at pc=0x00002ab49f329385, pid=8697, tid=1088649536

#

  1. Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0_03-b05 mixed mode)

  2. Problematic frame:

  3. C catgets+0x15

#

  1. An error report file with more information is saved as hs_err_pid8697.log

#

  1. If you would like to submit a bug report, please visit:

  2. http://java.sun.com/webapps/bugreport/crash.jsp

#
Aborted (core dumped)

Any suggestions?

/Sigmund

7 comments

Hello Sigmund,

When trying to execute idea.sh (build 7343) using java sun-1.5.0.11
(ubuntu feisty) I get this: "java.lang.UnsupportedClassVersionError:
Bad version number in .class file"

but when using java 1.6.0_03-b05 I get:

#

  1. An unexpected error has been detected by Java Runtime Environment:

#

  1. SIGSEGV (0xb) at pc=0x00002ab49f329385, pid=8697, tid=1088649536

#

  1. Java VM: Java HotSpot(TM) 64-Bit Server VM (1.6.0_03-b05 mixed mode)

  2. Problematic frame:

  3. C catgets+0x15

#

  1. An error report file with more information is saved as

hs_err_pid8697.log
#

  1. If you would like to submit a bug report, please visit:

  2. http://java.sun.com/webapps/bugreport/crash.jsp

#
Aborted (core dumped)
Any suggestions?


Could you please post the complete crash log (hs_err_pid8697.log)?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Isn't a JVM crash of that sort by definition not the fault of the application running on it, at least when no application-supplied native / JNI libraries are included?

In this case, it looks like a C library problems, perhaps a 32-bit / 64-bit thing or some kind of version mismatch.


Randall Schulz

0

Hello Sigmund,

Attached log


Please try to add the following line to idea.properties:
awt.toolkit=sun.awt.X11.XToolkit

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Solved.

Removed AWT_TOOLKIT="MToolkit" from my /etc/environment file.
I added it to fix issues with compiz fuzion and IntelliJ.

/S

0

Please sign in to leave a comment.