loading incoming changes...

Seems like this spikes up my memory/cpu usage like crazy for me.

I disabled this in general settings->configure history cache->refresh changes (unchecked)

how do i stop this process from kicking off?

I dont want repository or incoming changes to be populated this causes alot of mem/cpu

Message was edited by:
Andre Mermegas

6 comments

Hello Andre,

Seems like this spikes up my memory/cpu usage like crazy for me.

I disabled this in general settings->configure history cache->refresh
changes (unchecked)

how do i stop this process from kicking off?


Delete the system\vcsCache directory.

What VCS are you using, by the way?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Hello Andre,

p4


I would appreciate a CPU snapshot. We're using P4 here, and we don't see
any particular performance problems related to this feature.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

hey Dmitry,

after deleting that vcs directory it seems to be behaving nicely. maybe it had some old setting and was trying to synch my previously configured setup that had my entire p4 depot instead of just directory based mappings i need.

not sure. will update if i see it again. thanks.

0

Hello Andre,

after deleting that vcs directory it seems to be behaving nicely.
maybe it had some old setting and was trying to synch my previously
configured setup that had my entire p4 depot instead of just directory
based mappings i need.


If you delete the directory it will stop refreshing the changes altogether,
until you press "Refresh" in the Committed or Incoming Changes view again.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Could this be linked to http://www.jetbrains.net/jira/browse/IDEA-15413?

Whenever my Incoming Changes and Committed Changes are refreshing, I can barely use IDEA as my CPU is just being caned. Yesterday it took almost 10 minutes to refresh the VCS status.

Oh I should add that I'm using Subversion, rather than P4.

Message was edited by:
Simon Knott

0

Please sign in to leave a comment.