Artifact XX:war exploded: Server is not connected. Press 'Deploy' to start deployment.

Hello,

I'm evaluating IntelliJ to use as my IDE, but I have not been able to get my server to start.

Others on my team see a "connected to server" message, but I do not get that.

I've attached the log file.

Thanks,

- Tad



Attachment(s):
idea.log.zip
11 comments

Hello,

The log doesn't contain anything suspicios.

What server do you use?

Denis

0

Tad, please do the following:

1) replace the <IDEA home>/bin/log.xml with the attached one, or add the following lines at the end of the existing one:
   <category name="#com.intellij.javaee.oss.admin.jmx.JavaeeJmxAdminServerBase">

    <priority value="DEBUG"/> <appender-ref ref="CONSOLE-ALL"/>
  </category>

  <category name="#com.intellij.javaee.oss.util.AbstractConnectorCommand">
    <priority value="DEBUG"/> <appender-ref ref="CONSOLE-ALL"/>
  </category>

2) (re)start the IDEA
3) launch your Tomcat Run configuration and wait until it finishes the startup
4) attach produced IDEA log (Help -> Show Log in ...)
5) attach complete textual content of the Output tab

Regards,
Michael

Attachment(s):
log.xml
0

I am attaching the log file



Attachment(s):
IntelliJLog.txt.zip
0

Hello,

Your previous log was made by IDEA 12.0.4 so I've sent you the log.xml which is compatible with IDEA 12.0.x but does nothing for IDEA 12.1 -- where the last log had been produced.
Sorry for some confusion here.

Actually, there's no need for a log.xml with IDEA 12.1: if an application server isn't get connected before 'Stop' button press, then a warning with the possible connection problem should be displayed and the warning message should be logged in the event log.

So, with IDEA 12.1 please do the following:
- launch Tomcat run configuration
- wait until Tomcat finishes startup
- press Stop button
- attach screenshot with the warning
- attach content of the 'Event Log' tool window
- attach IDEA log
- attach complete textual content of the Output tab of the run configuration (you've forgot to attach this last time)

Please, attach all the requested information, so I can have the whole picture.

Regards,
Michael
0

Michael,

Thanks for your reply.  Sorry I didn't get you the information you needed the first time.  I think I have included everything this time.

- Tad


Output text:
/Users/tadlambjr/rlp/iqity/apache-tomcat-6.0.29/bin/catalina.sh run
[2013-04-09 08:53:59,221] Artifact cls:war exploded: Server is not connected. Deploy is not available.
Apr 9, 2013 8:53:59 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
Apr 9, 2013 8:54:00 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090
Apr 9, 2013 8:54:00 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 398 ms
Apr 9, 2013 8:54:00 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 9, 2013 8:54:00 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
Apr 9, 2013 8:54:00 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090
Apr 9, 2013 8:54:00 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 9, 2013 8:54:00 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/16  config=null
Apr 9, 2013 8:54:00 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 93 ms
Apr 9, 2013 8:54:10 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory manager
[2013-04-09 08:54:32,984] Artifact cls:war exploded: Server is not connected. Deploy is not available.  [Here I tried clicking on the war file name and pressing the Deploy button]
/Users/tadlambjr/rlp/iqity/apache-tomcat-6.0.29/bin/catalina.sh stop
Disconnected from server
Error: Password file read access must be restricted: /Library/Java/JavaVirtualMachines/1.6.0_37-b06-434.jdk/Contents/Home/lib/management/jmxremote.password

Event log
8:50:50 AM Frameworks detected: Hibernate, Spring frameworks are detected in the project Configure
8:53:56 AM All files are up-to-date
8:53:58 AM All files are up-to-date
8:54:32 AM All files are up-to-date
8:54:48 AM All files are up-to-date
8:55:34 AM All files are up-to-date
8:55:57 AM All files are up-to-date
8:56:26 AM All files are up-to-date
8:58:18 AM Application Server was not connected before run configuration stop, reason:
           Unable to ping server at localhost:1095



Attachment(s):
IntelliJ-startup_connection.pdf
IntelliJ-deployment.png
IntelliJ-server_settings.png
IntelliJ-screenshot.png
IntelliJLog.log.zip
0

Hello,

I can see from screenshots and from the output ('Error: Password file read access must be restricted: '...) that you are passing some JMX-related JVM options via CATALINA_OPTS environment variable.

Since IDEA 12, the Tomcat integration relies on JMX protocol to administrate Tomcat instances and passes the following JVM arguments itself (via JAVA_OPTS, yet they are not shown in UI):
-Dcom.sun.management.jmxremote=
-Dcom.sun.management.jmxremote.port=<'JMX port' field value>
-Dcom.sun.management.jmxremote.ssl=false
-Dcom.sun.management.jmxremote.authenticate=false


IDEA doesn't support any other set of JMX-related JVM options (security-related e.t.c.), so you need to remove your own JMX-related JVM options from the CATALINA_OPTS in your IDEA Tomcat run configuration.
If you really need to secure JMX access to your Tomcat instance (or affect JMX protocol in some other way), please open a YouTrack with the list of JMX-related options that you need to be supported.

Regards,
Michael
0

Michael,

I removed my CATALINA_OPTS variable settings so as to not set any jmx parameters myself.  I also renamed all of my jmxremote.* files by adding a '-backup' to the end of the filenames.  This is what I am getting now:


Output
/Users/tadlambjr/rlp/iqity/apache-tomcat-6.0.29/bin/catalina.sh run
[2013-04-11 12:05:09,793] Artifact cls:war exploded: Server is not connected. Deploy is not available.
Error: Password file not found: /Library/Java/JavaVirtualMachines/1.6.0_37-b06-434.jdk/Contents/Home/lib/management/jmxremote.password
Disconnected from server

Event Log
12:05:07 PM All files are up-to-date
12:05:09 PM All files are up-to-date
12:05:10 PM Application Server was not connected before run configuration stop, reason:
            Unable to ping server at localhost:1095



Attachment(s):
idea.log.zip
0

Hello

Removing jmx-related options from the CATALINA_OPTS variable should be enough.
You should keep jmxremote.* files with their original names, since Tomcat will produce 'Error: Password file not found: ...' otherwise.
I'm not sure, but possibly you need to revert jmxremote.* files to their initial content.
Then, you may keep your currently renamed jmxremote.* -backup files, but you need to place the initial versions of the files to the initial place(s).

HTH,
Regards,
Michael
0

Michael,

I think I have my jmx problems resolved now, and that made a big difference.  This is what the log is showing now:

Output:
/Users/tadlambjr/rlp/iqity/apache-tomcat-6.0.29/bin/catalina.sh run
[2013-04-11 02:42:27,807] Artifact cls:war exploded: Server is not connected. Deploy is not available.
Apr 11, 2013 2:42:28 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
Apr 11, 2013 2:42:28 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8090
Apr 11, 2013 2:42:28 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 346 ms
Apr 11, 2013 2:42:28 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 11, 2013 2:42:28 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.29
Apr 11, 2013 2:42:28 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8090
Apr 11, 2013 2:42:28 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 11, 2013 2:42:28 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/12  config=null
Apr 11, 2013 2:42:28 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 77 ms
Apr 11, 2013 2:42:38 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory manager
[2013-04-11 02:42:45,379] Artifact cls:war exploded: Server is not connected. Deploy is not available.
/Users/tadlambjr/rlp/iqity/apache-tomcat-6.0.29/bin/catalina.sh stop
Disconnected from server
Error: Exception thrown by the agent : java.rmi.server.ExportException: Port already in use: 8999; nested exception is:
    java.net.BindException: Address already in use

Event Log:
2:38:55 PM All files are up-to-date
2:38:57 PM All files are up-to-date
2:38:57 PM Application Server was not connected before run configuration stop, reason:
           Unable to ping server at localhost:1095
2:41:04 PM All files are up-to-date
2:41:05 PM All files are up-to-date
2:41:21 PM All files are up-to-date
2:41:47 PM Application Server was not connected before run configuration stop, reason:
           Unable to ping server at localhost:1095
2:42:26 PM All files are up-to-date
2:42:27 PM All files are up-to-date
2:42:45 PM All files are up-to-date
2:42:47 PM Application Server was not connected before run configuration stop, reason:
           Unable to ping server at localhost:1095



Attachment(s):
idea.log.zip
0

Hi Michael,

I'm having the same trouble, except I DO need the jmx-stuff in catalina.sh, namely:
-Dcom.sun.management.jmxremote.port=7009 -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.authenticate=false

Is the Youtrack remark still the only solution? If so, can you please advise - for I am unfamiliar with the process?

Thanks!

0

Please sign in to leave a comment.