IDEA puts all pom.xml files into ignoredFiles on git checkout

Hi,
A really annoying thing keeps happening whenver I change branch with a git checkout - IDEA puts all my Maven module pom.xml files into a <option name="ignoredFiles"> element in .idea/misc.xml, so all modules disappear from the project. I have to manually remove this section from misc.xml. Normally I do the git checkout on command line as there are a few  glitches in IDEA's git integration. I think it also happens if I git  checkout within IDEA - I can verify this if this is not a known issue  and you need me to. Is there a workaround, and should I raise this as a bug?
Alex

7 comments

Hi.

A blind guess: maybe your Settings / Version Control / Ignored Files contain corresponding pattern?

Regards,
Alexander.

0

I have only .iws, workspace.xml in settings | version control | ignored files

0

Could you please attach the whole misc.xml file please?
If it contains valuable information, you can raise a bug visible to jetbrains-team only.

0

Please, attach $PROJECT_DIR$/pom.xml

0

Hi Sergey,
If you PM or email me, I can email you my pom.xml
Regards,
Alex

0

Please sign in to leave a comment.