No copyright added for new files in IntelliJ 12.1.3

Even if I have a default copyright profile set, no copyright is generated when a java new file is created.

I've tried adding an "All" scope for this profile and does not work either.

6 comments

I suspect something is incorrectly configured since we're not having that issue in 12.1.3. You might want to double check the settings in Copyright > Formatting > Java to make sure the "No Copyright" option is not selected. Other than that, I can't think of anything else.

Out of curiosity, is the copyright generated is you run the "Update Copyright" action on the file?

0

Copyright -> Formatting -> Java is set to "Use default settings"

It's manually added when I do: Cmd + N and select "Copyright" on the file.

0

I've tried the "Update Copyright" action and that works too.

0

Well, I 'm at a loss. The only two other things I can suggest are:

  1. Disable all third party plugins, restart and try it. Perhaps a plugin is interfering with the new file creation sequence of events.
  2. See if there is anything in the logs that might give a clue. (Help > Show Log)

Perhaps someone else might have some ideas.

0

This site is sooooo SLOW!!!!!!!!!!

Back to the question:
- I've disabled all custom plugisn, no luck.
- Nothing appears in the logs WRT copyright

:(

0

This is happening to me too. Everything is configured correctly but no copyright is added to new files. I have to do it manually which is very bad.

0

Please sign in to leave a comment.