java: invalid source release: 8

Hello all! I have been downloaded Android Studio from Google developers. But when I want to start my project, I see the next error:
Записати.PNG
How can I fix this? I didn't found any solution on stackoverflow, so maybe here I will found the answer...Thanks in advance

9 comments

Hi Max,

Please provide your settings (main menu | file | export settings)

Denis

0

They look ok for me.

Could you provide a minimal but complete sample project which shows the problem at your environment?

Denis

0

I removed .apk files for less file size. It's my project



Attachment(s):
Apotheke.zip
0

Asked our android guy to have a look

Denis

0

If it can be helpful, so I created this project in Eclipse, and imported in free version of IntelliJ IDEA, and now - in Android Studio. But when I start new project in AS - it don't looks like project from Eclipse

0

Hello again! do you have look to my project?

0

Sorry about the delay. The problem is that "java 1.8" language level is chosen for the module (see Project Structure | Modules | <your_module> | Sources), but you compile with JSDK 1.6 or 1.7. Did you choose this manually?

0

No, it was chosen already. Thanks, I will try this solution.

0

Please sign in to leave a comment.