IntelliJ V12 pre-processing ant task with input locks up build process

Hi All,

I have an artifact defined with a pre-processing ant task that uses an input task to ask the user for a parameter.  This is apparently causing the build process to completely lock up.  everything looks like it is running but the statusbar just says "building artifact myArtifact:war exploded" and sits and spins.  When I remove the pre-processor, the artifact compiles and builds.  I can run the pre-processor just fine from the ant build window separately and it will pop up a dialog for entering the parameter.

This was working in 10.5.4 and I just upgraded today.  

Thank you
Robert Brown

4 comments

Hi Robert,

Could you provide a sample project which illustrates the problem?

Denis

0

Yep here you go.  

If you run the artifactFail task directly from the ant console the input will pop up.  If you run the Build -> Build Artifacts from the menu it will lock up (apparently trying to display and receive a response from the input box).  This works in IntelliJ 10

Thanks
Bob



Attachment(s):
Artifact Build Fail.zip
0

The ide uses 'external build' by default, i.e. it starts a separate process to perform tasks like 'make project', 'build artifacts' etc. There is no support for ant's <input> task there.

You can create corresponding ticket at IJ tracker or use in-process make (uncheck 'project settings | compiler | use external build'

Denis

0

Ah, I see and V10 didn't have an external option so it worked.  Figured it was somehting like that.  

Unchecking the external compile does work.

Thanks
Bob

0

Please sign in to leave a comment.