Cursor type

Hi

My current Intellij version 12.1.4.

I play some settings and my cursor shape turned rectange  in insert mode and normal line ( | ) in overwrite mode.How can i fix that ?

When I press "insert" button; insert and overwrite modes are working but cursor shape is reversed :)

Any suggestions ?

Thanks.

7 comments

Hello,

Please uncheck the followin box - ide settings | editor | appearance | use block caret

Denis

1

denis.zhdanov wrote:

Hello,

Please uncheck the followin box - ide settings | editor | appearance | use block caret

Denis

or much easier: press "insert" key

0

No, 'Insert' switches between block and regular caret, the thing is that when you check 'use block caret', regular caret looks like 'block'.

Denis

0

Thank you Denis. I had same problem for few months and can't google how to switch it.

0

Have the same problem, but Denis`s advice not helped in my case. I am tried to reinstall Intellij, but settings not changed. Please, help me to uninstall Intellij completely, or another way to fix this bug.

0

Please sign in to leave a comment.