Selena 7274 Fails at Startup (Mac OS X)

I am running Selena on Mac OS X and on a fresh install I see the following error at startup. I was running M2 previously, which still runs if I reinstall it. I need the groovy plugin, which means I have to 7274 so help would be appreciated.

Thanks.

Using JVMTI (1.5.0_07-87;"Apple Computer, Inc.";mixed mode, sharing;Mac OS X;32 bit JVM)
Profiler agent is listening on port 10001...
*** HINT ***: To get profiling results, connect to the application from the profiler UI
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.intellij.ide.plugins.PluginManager$4.run(PluginManager.java:422)
at java.lang.Thread.run(Thread.java:613)
Caused by: java.lang.IllegalArgumentException: Validation failed
at com.jetbrains.licenseServer.openapi.util.ClientUtil.a(ClientUtil.java:93)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:8)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:31)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.ping(ClientUtil.java:40)
at com.intellij.ide.a.c.j.a(j.java:51)
at com.intellij.ide.a.c.j.a(j.java:217)
at com.intellij.ide.a.c.j.a(j.java:137)
at com.intellij.idea.MainImpl._main(MainImpl.java:20)
at com.intellij.idea.MainImpl.start(MainImpl.java:24)
... 6 more
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.intellij.ide.plugins.PluginManager$4.run(PluginManager.java:422)
at java.lang.Thread.run(Thread.java:613)
Caused by: java.lang.IllegalArgumentException: Validation failed
at com.jetbrains.licenseServer.openapi.util.ClientUtil.a(ClientUtil.java:93)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:8)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:31)
at com.jetbrains.licenseServer.openapi.util.ClientUtil.ping(ClientUtil.java:40)
at com.intellij.ide.a.c.j.a(j.java:51)
at com.intellij.ide.a.c.j.a(j.java:217)
at com.intellij.ide.a.c.j.a(j.java:137)
at com.intellij.idea.MainImpl._main(MainImpl.java:20)
at com.intellij.idea.MainImpl.start(MainImpl.java:24)

9 comments
Comment actions Permalink

On 2007-09-19 22:08:59 +0400, Mark Udstrand <no_reply@jetbrains.com> said:

at
com.jetbrains.licenseServer.openapi.util.ClientUtil.a(ClientUtil.java:93)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:8)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.executeRpc(ClientUtil.java:31)
at
com.jetbrains.licenseServer.openapi.util.ClientUtil.ping(ClientUtil.java:40)


Add

-Doldlicenseserver to VMOptions in Info.plist for now.

0
Comment actions Permalink

here is how i got it to work...

(first see that you have the JDK 6, yes the b88 from 09/2006, installed)

open and edit Info.plist (Show Package Contents on IntelliJ IDEAxxx.app, go into Contents, double-click Info.plist):
- open "Root", then open "Java"
- modify "JVMVersion" from "1.5" to "1.6"
- edit "VMOptions" and remove "-agentlib:yjpagent"
- save/close

(the yourkit profiling agent shipped with IDEA is v6 which does not work w/JDK6... yourkit 7 does, fyi)

Now IDEA should run using JDK 6 and the JetGroovy plugin should function as well.

0
Comment actions Permalink

On 2007-09-19 22:57:53 +0400, k <krsjunk@netscape.net> said:

here is how i got it to work...

(first see that you have the JDK 6, yes the b88 from 09/2006, installed)

open and edit Info.plist (Show Package Contents on IntelliJ
IDEAxxx.app, go into Contents, double-click Info.plist):
- open "Root", then open "Java"
- modify "JVMVersion" from "1.5" to "1.6"
- edit "VMOptions" and remove "-agentlib:yjpagent"
- save/close

(the yourkit profiling agent shipped with IDEA is v6 which does not
work w/JDK6... yourkit 7 does, fyi)

Now IDEA should run using JDK 6 and the JetGroovy plugin should
function as well.


This is plain wrong. MacOS X distribution of IDEA is compiled with 1.5
compiler thus 1.5 JRE compatible. Moreover, we highly discourage using
1.6 preview on MacOS. It's just too unstable, unperformant and has
numerous known issues we wouldn't like to deal with.

0
Comment actions Permalink

but the JetGroovy plugin (now) requires JDK6

and all i said was "here is how i got it to work" -- not saying anything about right or wrong.

i think it is wrong that the JetGroovy plugin is-built-with/requires JDK6

Message was edited by:
k

0
Comment actions Permalink

JetGroovy is indeed compiled with 1.6, this is my bug and I'll address it ASAP.

0
Comment actions Permalink

thank you, I'll be looking for it so I can switch back (although I haven't had any problems w/JDK6 except some minor paint issues)

0
Comment actions Permalink

k wrote:

thank you, I'll be looking for it so I can switch back (although I haven't had any problems w/JDK6 except some minor paint issues)


minor?

For me they are very annoying.

I am also looking forward to get back to jdk1.5... and even more to get a decent jdk1.6 for
macosx.


Regards,
Dirk

0
Comment actions Permalink

new vesion of JetGroovy is available in plugin manager

0
Comment actions Permalink

Eugene Vigdorchik wrote:

new vesion of JetGroovy is available in plugin manager


Thanks!

Works with JDK1.5 on MacOS X in 7291.


Dirk

0

Please sign in to leave a comment.