#7274 'Changes' panel broken.

In #7274 only the Changes panel 'Local' tab is usable for me. The 'Repository' and 'Incoming' tabs both create errors as soon as they are selected, and the panel remains blank.

This is in a completely clean install of #7274, with an existing project using CVS. I can do other CVS operations OK, but the 'Changes' panel is broken.

I had this problem in #7269, but deleting the caches and restarting IDEA fixed it. This fix doesn't work with #7274.

I have reported the errors via the 'Blame' dialog.

5 comments
Comment actions Permalink

Further information:

I reverted to #7269 and cleared out all the caches before loading the project, but the Changes panel problem appeared as soon as the project loaded. Now both #7274 and #7269 Changes panels are unusable. Maybe the IDEA project files are corrupted?

I'll revert to the Milestone 2 build, and if that doesn't work, I'll recreate the project from scratch :(

Later...

Project loaded into fresh install of IDEA Milestone 2 (#7126), and all the CVS Changes panel stuff is now working fine. Phew!

I shall have to abandon the EAP until the CVS Changes panel has been fixed.

Message was edited by:
Dave Lorde

0
Comment actions Permalink

I think changes stuff is stored in the iws only, so you might want to
try getting rid of that first before zapping the whole project. No idea
if that would work though...

N.

Dave Lorde wrote:

Further information:

I reverted to #7269 and cleared out all the caches before loading the project, but the Changes panel error appeared as soon as the project loaded. Now both #7274 and #7269 Changes panels are unusable. Maybe the IDEA project files are corrupted?

I'll revert to the Milestone 2 build, and if that doesn't work, I'll recreate the project from scratch :(

0
Comment actions Permalink

Thanks for the suggestion, but if I delete the iws files, I lose the modules, so I pretty much have to recreate the whole thing anyway...

0
Comment actions Permalink

Ah do you? I thought they were in the IPR. Oh well.. good luck anyway!

N.

Dave Lorde wrote:

Thanks for the suggestion, but if I delete the iws files, I lose the modules, so I pretty much have to recreate the whole thing anyway...

0
Comment actions Permalink

Got it sorted in the end by copying a set of project files from a Milestone 1 backup. Changes panel now working fine in #7274 :)

0

Please sign in to leave a comment.