Env variable problem in Selena Debugger

This is a followup to another post. I thought it was a firewall problem,
but I get the following

ERROR: transport error 202: unable to create socket: Provider
initialization failed (check %SystemRoot%) ["transport.c",L41]
FATAL ERROR in native method: JDWP No transports initialized,
jvmtiError=JVMTI_ERROR_INTERNAL(113)
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT
(510) ["debugInit.c",L500]
JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports initialized
Process finished with exit code 1


when I tried setting using the ENV variable option of the debugger in
Selena. Even a simple

EnvVar2=jj

using the tool to add a variable doesn't work.

Is this tool supposed to allow me to set env variables that can be
accessed via System.getenv()?
--
-


David H. McCoy


-


2 comments
Comment actions Permalink

Hello David,

This may relate to the issue: http://www.jetbrains.net/jira/browse/IDEADEV-20158.

This is a followup to another post. I thought it was a firewall
problem, but I get the following

ERROR: transport error 202: unable to create socket: Provider
initialization failed (check %SystemRoot%) ["transport.c",L41]
FATAL ERROR in native method: JDWP No transports initialized,
jvmtiError=JVMTI_ERROR_INTERNAL(113)
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT
(510) ["debugInit.c",L500]
JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports initialized
Process finished with exit code 1
when I tried setting using the ENV variable option of the debugger in
Selena. Even a simple

EnvVar2=jj

using the tool to add a variable doesn't work.

Is this tool supposed to allow me to set env variables that can be
accessed via System.getenv()?

--------------------------------------

Alexander.


0
Comment actions Permalink

Right. My settings are blowing away everything else. Thanks!
In article <c8a8945a72b98c9c2c153c92ab0@news.intellij.net>,
Alexander.Chernikov@jetbrains.com says...

Hello David,

This may relate to the issue: http://www.jetbrains.net/jira/browse/IDEADEV-20158.

This is a followup to another post. I thought it was a firewall
problem, but I get the following

ERROR: transport error 202: unable to create socket: Provider
initialization failed (check %SystemRoot%) ["transport.c",L41]
FATAL ERROR in native method: JDWP No transports initialized,
jvmtiError=JVMTI_ERROR_INTERNAL(113)
ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT
(510) ["debugInit.c",L500]
JDWP exit error JVMTI_ERROR_INTERNAL(113): No transports initialized
Process finished with exit code 1
when I tried setting using the ENV variable option of the debugger in
Selena. Even a simple

EnvVar2=jj

using the tool to add a variable doesn't work.

Is this tool supposed to allow me to set env variables that can be
accessed via System.getenv()?

--------------------------------------

Alexander.



--
-


David H. McCoy


-


0

Please sign in to leave a comment.