aapt not found after build-tools r17 update?

using latest production Idea 12.1.3 after updating the Android build tools from Google to r17, and trying to compile an Android project, I see error

     android-apt-compiler: Cannot run program "/Users/lhamel/tools/android-sdk-mac_x86/platform-tools/aapt": error=2, No such file or directory

Can you duplicate this?

the executable seems to have moved:


   $ find  ~/tools/android-sdk-mac_x86/ -name "aapt"

          ~/tools/android-sdk-mac_x86//build-tools/17.0.0/aapt

in other words, r17 may have moved it.


caveat:  I tried out the EAP version on this same project, so it could be damaged...

thanks,

larry

9 comments

Confirmed under Windows 7.

Neither Idea 12.1.3 nor Android Studio working for me today: Android Studio complained about outdated SDK version and after updating it (together with platform tooks) Idea stopped working.
Embarassing.

0
This is true.  What's worse is there is no way to edit this in the project or app settings I can find.  So now IDEA is useless and I cannot compile.  Nice of the Intellij folks to mark this as "answered" though (above). This question is answered (aapt not found repros) but the issue remains open (IntelliJ is broken).  But that's not a problem. I guess if I plan to remain productive and ship product by next week I can uninstall ADK and seek out an old version, lov.ing.it.  THANKS
0

I got the EAP 13 to compile for me.  try that?

0

COnfirmed on Windows 8 - 64 bit.
It crashed after upgrading SDK :(

Hey JetBrains - any suggestions ?

0

I'm sure this will be fixed upstream swiftly but in the meantime the quick fix is easy.

The structure of the SDK seems to have changed, so for now just copy the contents of /build-tools/17.0.0 to /platform-tools (tested on Linux)

And enjoy :)

0

Confirmed. on Ubuntu.

Anyway, I copied contents of folder build-tools/17.0.0 into platform-tools and problem solved.

0

Create soft links from platform-tools to build-tools/17.0.0/aapt and build-tools/17.0.0/lib.

ln -s ./build-tools/17.0.0/aapt ./platform-tools/appt
ln -s ./build-tools/17.0.0/lib ./platofrm-tools/lib

It will solve the problem.

I hope JetBrains will update IntelliJ soon.

0

Here is correct commands for symlinks:
ln -s ../build-tools/17.0.0/aapt platform-tools/aapt
ln -s ../build-tools/17.0.0/lib platform-tools/lib

0

Hello, I have Windows 8 64 bit and I have just made a new install of IntelliJ Idea, JDK and Android SDK When trying to compile a hello world project, found the following error:
android-apt-compiler: Cannot run program "C:\Program Files\ADT\adt-bundle-windows-x86_64-20130514\sdk\platform-tools\aapt.exe": CreateProcess error=2, The system cannot find the file specified
I assume it is due to the issue mentioned earlier. However, I don't have the aapt.exe file in the folder mentioned here (the folder does not even exist).
I have found three aapt.exe files in the following folders:
C:\Program Files\ADT\adt-bundle-windows-x86_64-20130514\sdk\platforms\android-3\tools (11.4 MB)
C:\Program Files\ADT\adt-bundle-windows-x86_64-20130514\sdk\platforms\android-4\tools (11.4 MB)
C:\Program Files\ADT\adt-bundle-windows-x86_64-20130514\sdk\build-tools\android-4.2.2 (835 KB)

Which one should I use copy to the folder platform-tools for the compile process to work?

My test project is for android 4.0, but I may also build for earlier versions once I learn to develop for Android.

0

Please sign in to leave a comment.