3 comments
Comment actions Permalink

Basically you always get this error in java when an older JRE tries to load classes that were compiler with a newer one.
So either JetBrains mistakenly compiled something with JDK 1.6 or you accidentally use an older JDK version than for older EAP builds.

Anyway try using JDK 1.6.

Omair-Inam Abdul-Matin wrote:

I get an unsupported class version error when I try to start up IDEA... Anyone have any ideas why?


------------------------------------------------------------------------

0
Comment actions Permalink

Oh, I just remembered that the final 7.0 *.exe (windows only) was announced to be compiled with 1.6
(to take advantage of some performance enhancements).
Maybe they just did this (I would not notice as I am running with 1.6 anyway).

Omair-Inam Abdul-Matin wrote:

I get an unsupported class version error when I try to start up IDEA... Anyone have any ideas why?


------------------------------------------------------------------------

0
Comment actions Permalink

Stephen Friedrich wrote:

So either JetBrains mistakenly compiled something with JDK 1.6 or you
accidentally use an older JDK version than for older EAP builds.


Yes, they did, but no, it's not a mistake. See
http://www.jetbrains.net/confluence/display/IDEADEV/EAP7269Release+Notes

Sascha

0

Please sign in to leave a comment.