selena M2 - Right Click menus no longer work

I can't select any items in a right click context menu. i.e. right clicking on a variable name, I cannot select 'Find Usages'. It does not appear greyed out. When I try click on it, the menu disappears. The menu never shows a highlight over the item my mouse is hovering on. The top level menubars work fine (File, Edit, etc...). Selena M2, OSX 10.4.latest.

I should add, I can navigate those right click menus using the arrow keys still.

Message was edited by:
Ecornips



Attachment(s):
pastedGraphic.png
12 comments
Comment actions Permalink

Weird cause I can....

0
Comment actions Permalink

This was reported in http://www.jetbrains.net/jira/browse/IDEA-14142 (7118) and remains (but not as bad) in M2

Sometimes it will work if right-drag (holding the right mouse button down until selection has moved to the desired item). Seems to happen less often if the windows where the right click happen does not have focus (may just seem like it)

This never happened to me before 7118.

0
Comment actions Permalink

just like to add a "me too"

very frustrating.... seems to come and go too. right clicking could work find for an hour and then stop. or only every other right click works. or after switching to another app and coming back to IDEA it start working again.

same scenario though, the arrow keys always work after right clicking even if moving the mouse doesn't select anything

0
Comment actions Permalink

Me three! The odd thing about it was that the problem seems considerably worse in M2 than it has in the past. It isn't entirely consistent though. Sometimes I can shutdown and restart IJ and it starts working again.

0
Comment actions Permalink

Wow, I am glad (sort of) to see this thread. I thought I was just losing my mind, or control of my mouse gestures or needed a new mouse or something. Its definitely there in M2 for me.

0
Comment actions Permalink

Hi,

Wondering if this problem been acknowledged officially (or semi officially) yet?

0
Comment actions Permalink

Hello Spencer,

Wondering if this problem been acknowledged officially (or semi
officially) yet?


We got reports of this problem a short time before M2, and we thought that
we fixed it for the final M2 release, but it looks like our fix was incomplete.
This will certainly be included in the M2 bugfix as soon as we find a way
to reproduce and fix this problem.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks for the update. I am noticing this problem on the Mac, but it sounded like at least at point, it was not limited to the Mac. However, another Mac Idea user similar hardware has not mentioned the problem to me, so I can see where it might be tricky to track down.

Let me know if I an be of any assistance here.

0
Comment actions Permalink

It is also happening on a Windows Machine (XP SP2).

Besides that, I suddenly can't "Code - Generate" (Alt-Insert) anymore. Not via the main menu and not directly with the keyboard. The little Window just does not appear. I wanted to mention it here, because there might be some connection with the popup-Menu problem.

Regards
Hans

0
Comment actions Permalink

There does seem to be some problems with the key or action handling - for a while the 'Find Usages In File' Ctrl-F7 key stopped working altogether, although all other 'Find' options worked OK. Then I stopped and reloaded IDEA, and it started working again. This has happened a couple of times since then.

0
Comment actions Permalink

Do you mean CTRL+F7 stopped resopnding at all, or it stopped finding any uses (telling you so). I've encountered the latter: http://www.jetbrains.net/jira/browse/IDEA-14299

"On an occasional basis, the "Find Usages in File" (CTRL+F7) will cease to find any instances, instead always showing the "Usages of XYZ not found" diagnostic on every attempt.

"Once this symptom occurs, the only way to recover the functionality is to restart IDEA."


Randall Schulz

0
Comment actions Permalink

Yup, not finding any uses was the problem.

Voted for it.

Message was edited by:
Dave Lorde

0

Please sign in to leave a comment.