Is there any way to turn off the automatic code analysis?

Because the M2 Intellij becomes quite unresponsive on my computer at work. I am editing a 4500 LOC file and if I make one character change, it starts to analyze the whole thing and the CPU usage goes up to a 100% and it slows down a lot of things. This machine is old...its a Northwood P4 with 2 gig of RAM running at 2.4 GHz.

I switched back to Intellij 4.5.4 temporarily and it does not have this problem as the number of inspections it runs is 0 it seems by default. I would like to turn off the code analysis while editing. I will only enable it right before I commit so I can clean up my code. That possible?

5 comments
Comment actions Permalink

Hello Surya,

Because the M2 Intellij becomes quite unresponsive on my computer at
work. I am editing a 4500 LOC file and if I make one character change,
it starts to analyze the whole thing and the CPU usage goes up to a
100% and it slows down a lot of things. This machine is old...its a
Northwood P4 with 2 gig of RAM running at 2.4 GHz.


Could you please take a CPU snapshot so that we can investigate why this
is so slow?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Click the little man at the bottom of the window. Move the slider to the left.

0
Comment actions Permalink

Hello,

if I understand correctly your problem, only one of the files in your
project is too large. In such a case you can turn off code inspection
for the single file only and keep inspections active for the rest of
your project. In fact, I cannot imagine myself coding without
inspections on.
To do so:
1. create a scope for the big file in the Scopes configuration dialog
2. create a shared inspection profile with no inspections selected and
assign it to the new scope in the Errors configuration dialog

I hope this helps resolve your problem.

Vaclav

0
Comment actions Permalink

Clicking the little man and sliding it over till where it says Syntax has definitely helped. Its not so much that the IDE becomes unresponsive...but it just becomes jerky and it seems UI latency goes up. With 4.5.4 there is none of that at all. It is FAST!

And on another note, how do you do the CPU snapshot again?

0
Comment actions Permalink

Hello Surya,

And on another note, how do you do the CPU snapshot again?


Add -agentlib:yjpagent to idea.exe.vmoptions and use the toolbar button to
start and stop recording the CPU activity.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.