python project shows no files after plugin update from 2.10.0 -> 2.10.1

Hi Folks. The 2.10.0 plugin has been working for many months, but today when I updated to 2.10.1 my python project no longer
shows any packages, just files at the project's (Git) repository root. I tried re-opening the project, restarting IDEA, unchecking the plugin, restarting, checking it, and restarting, but no joy. ?:| I also tried downloading the 2.10.0 version from JetBrains Plugin Repository :: Python ( http://plugins.jetbrains.com/plugin/?id=631 ) but got an error: "Plugin Python is incompatible with current installation". Drat! This is a major problem. Suggestions, please? Thank you -- matt

idea/plugin version combinations:
intellij    python plugin    result
12.1        2.10.1           nope
12.1        2.10.0           Error: Plugin Python is incompatible with current installation
12.0.4      2.10.1            ""
12.0.4      2.10.0            worked



Mac OS X 10.7.5

9 comments

I get the same problem on my mac.
Same idea/mac version, also update the python plugin.
I saw this ticket http://devnet.jetbrains.com/message/5483967#5483967 but the solution in this thread won't solve the problem.

0

I agree that this is a different situation. I proved my modules all exist when I downgraded to the previous version and everything worked fine.

JetBrains: Could we please have a reply?

0

Please attach the screenshots of the project view and the project structure dialog.

0

the problem is solved after upgrade from 12.1 to 12.1.1

0

The attached project-view-lost-files.png shows the broken Project view in 12.1.1. The other - project-view-correct.png - shows what it's supposed to look like. I've also attached the .iml and modules.xml files from my project.  I'm happy to provide whatever else you need. Note: I just verified that the problem still exists after upgrading from IntelliJ IDEA 12.0.4 to 12.1.1, which, upon first run, asked to also update python plugin from 2.10.0 -> 2.10.1 . I'd really appreciate your help in figuring out what is wrong - it would be nice to take advantage of your hard work in the new versions, esp. the python plugin, which we use a lot.



Attachment(s):
modules.xml
causality.iml.zip
project-view-lost-files.png
project-view-correct.png
0

The module file looks correct to me. Could you please check if your project path is included in the list of paths of your selected Python SDK? This could cause it to be displayed under External Libraries rather than in the root of the project view.

0

Thanks for the reply, Dmitry. Under "Project Structure > Project > Project SDK", <No SDK> is displayed in red. Is this what you meant for me to look at? I'm fairly certain I've had this set to "Python 3.2.3 (/System/Library/Frameworks/Python.framework/Versions/3.2/bin/python3.2) (Python 3.2.3)" in  the past, but I think it resets somehow when I move between machines with different versions of Mac OS X. Just in case, I tried upgrading from 12.0.4 to 12.1.1, changing above to 3.2.3, and looking at External Libraries rather than in the root of the project view. There was no change - the project doesn't show. I've attached a screen shot. What else can I try? Thank you -- matt



Attachment(s):
mc-0424-idea-no-project-shown.png
0

I figured out that this line in our .iml file was causing the problem:

   <orderEntry type="library" name="code" level="project" />
0

Scratch that - I didn't test carefully, and my 'solution' broke the code.

Please: JetBrains folks: Could you have a look at this and tell me what more I can do?

0

Please sign in to leave a comment.