Error with testng plugin and 7104 (linux)

This occurs when right-clicking and Run

com.theoryinpractice.testng.TestNGConsoleView.createUpDownStacktraceActions()[Lcom/intellij/openapi/actionSystem/AnAction;
java.lang.AbstractMethodError: com.theoryinpractice.testng.TestNGConsoleView.createUpDownStacktraceActions()[Lcom/intellij/openapi/actionSystem/AnAction;
at com.intellij.execution.runners.RunContentBuilder.a(RunContentBuilder.java:61)
at com.intellij.execution.runners.RunContentBuilder.a(RunContentBuilder.java:2)
at com.intellij.execution.runners.RunContentBuilder.showRunContent(RunContentBuilder.java:49)
at com.intellij.execution.runners.RunStrategyImpl.a(RunStrategyImpl.java:80)
at com.intellij.execution.runners.RunStrategyImpl.access$200(RunStrategyImpl.java:62)
at com.intellij.execution.runners.RunStrategyImpl$3.run(RunStrategyImpl.java:6)
at com.intellij.execution.impl.ExecutionManagerImpl$1.run(ExecutionManagerImpl.java:5)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:21)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:6)
at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:180)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:48)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

2 comments
Comment actions Permalink

This might be caused by conflicts with the builtin version (not sure though).

0
Comment actions Permalink

Hello,

Indeed it's conflict version of old TestNG plugin and new IDEA version. Could
you please remove old plugin and use one from IDEA installation

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

This might be caused by conflicts with the builtin version (not sure
though).



0

Please sign in to leave a comment.