paste without indenting?

Sometimes I want to copy and paste a section of minimized javascript code into intellij.

When I do this, it always adds tabs on new lines --- trying to format the code.

How can I prevent this when pasting?  As a workaround, I open the file in sublime text and paste there.

2 comments

Hello,

You can disable that permanently by settings 'ide settings | editor | smart keys | reformat on paste' to 'none'. Alternatively, you can use 'Pate Simple' action (mapped to Ctrl+Alt+Shift+V at the default keymap).

Denis

1

Thanks God for me to find this setting. For a python document, pasting text as simple as " a b c" without quotes and starting with a blank space, resulted in an astonishing wrap:

a
b
c

 

 

 

 

0

Please sign in to leave a comment.