Deleting a tab symbol

I was looking in keymap shortcuts but couldn'd find it.
In eclipse if ure using a tab to format code backspace and delete buttons remove the whole tab symbol, while in intelliJ even if a single tab symbol was inserted it is still being deleted char by char.

Sorry for dummy questions but the wholy bunch of miscelaneous trifles makes life more convinient :)

5 comments

Actually, you use spaces instead of tabs.
It's here: Settings -> Code Style -> General -> Use tab character

0

Doesn't work for me, still deletes tabs char by char. I've found workaround though, if i put caret at a place where i need to remove tab - shift+tab move a line left by 1 tab character.

p.s. thought delete option would be handy

0

Hi Georgy,

I believe the document you're working with actually contains not tabs but spaces at that position. You can check that by enabling ide settings | editor | appearance | show whitespaces.

Denis

0

I have that checkbox "use tab character" marked for current project (internal values are 4,4,8). Restarted IntelliJ (just in case) I'm creating a new class

public class StaticTest {
     public static void main (String[] args) {
          System.out.println("Testing tabs");
     }
}


All those indents are made with tab symbols, but with "show whitespaces" option turned on, any tab symbol i insert is shown as 4 spaces.

Am i doing something wrong?

0

I've found the problem. I needed to mark a checkbox not in general tab, but in Java one. After making it, it started to work

0

Please sign in to leave a comment.