JavaFX with JDK6 in IDEA 12.1?

I've installed version 12.1 and am trying to figure out how to make a JavaFX project work. I've created a new JavaFX project, but I can't compile it due to missing javafx.* dependencies. I have the latest JDK6 installed (we can't move to 7 yet), and I installed the JavaFX SDK from Oracle, but I don't see any way to easily add the required jars to the project. I had assumed that I would be asked to create a library if needed, similar to Grails project creation. Do I simply need to create a new library manually and add the jars installed with the JavaFX SDK? If so, which jars do I need?

1 comment

Chad, unfortunately IDEA doesn't support JavaFX for JDK 6 so if you can't use JDK 7 you need to setup a libarary manually.

.fxml editing as well as css support would work, thought I expect that packaging won't work. You would need to generate ant build.xml and run it from ant toolwindow (you would need to add JavaFX library to additional ant classpath).

Sorry for the inconvenience.

0

Please sign in to leave a comment.