How IDEA treate a file encoding as "not configured"?

For some reasons my file encoded by GBK.
When I import the module to IDEA, I must set every file in status bar from UTF8 to GBK.
But I already read the online web documents, set the IDE encoding and project encoding to GBK.(I do the set encoding action after import the project)
And, it not always be able to set the file's encoding, the status bar is gray.

The document says the encoding is not configured, but why?

2 comments

Hello.

What IDEA version do you use?

In any case, a couple of tricks is:
1. Try IDE restart after editing encoding settings (like project encoding), if not yet: some changes in encoding settings are applied only after that.
2. Check Settings / File Encodings / "Autodetect UTF-encoded files" off. (And restart the IDE.)

Regards,
Alexander.

0

IDEA 12 running on Ubuntu 12.10
After restarting the IDE, it seems fine. If there's further issue, I will feedback.
Thanks.

0

Please sign in to leave a comment.