FreeMarker realoding problem

I have problem with intellij idea 12, everytime i edit FreeMarker (.ftl) file and run application again it doesnt reload file and instead keeps using old version of file.

If I close my project open it with idea 11 run application, and then go back to idea 12 (or keep using 11) everything works fine.

Invalidating cache doesnt work either.

anyone know what might cause the problem and how to solve it?

5 comments
Comment actions Permalink

What's the value of Settings | Compiler | Resource patterns?
Do you compile your project before run?
If you invoke Compile (Ctrl+Shift+F9) on the ftl file before running the project explicitly, do you get the same issue?

0
Comment actions Permalink

"What's the value of Settings | Compiler | Resource patterns?"

?*.properties;?*.xml;?*.gif;?*.png;?*.jpeg;?*.jpg;?*.html;?*.dtd;?*.tld;?*.ftl

In both idea 11 and 12, I simply imported settings from idea 11

Compiling ftl file manually doesnt work either, fun thing is if I rebuild project it cant event "detect ftl file" and dropwizard says missing template. If I go back to to idea 11 eveything works fine

For example if I have template named test.ftl it says missing template /com/test/app/views/test.ftl although file is located there.


At first i thought it might be some overlooked edge case and problem with dropwizard but every time i switch back to idea 11 everything just works as it should, so I suspect it might be bug in idea 12

0
Comment actions Permalink

Could you please try disabling Settings | Compiler | Use external build and rebuild project? Does this help?

0
Comment actions Permalink

Yep that solved the problem. Thanks a lot

0
Comment actions Permalink

Please make sure the module where your resource file is located, is not imported from maven pom.xml. If this is the case, then all resources are processed according to settings specified in the pom.xml and not in Settings | Compiler | Resources. For all non pom.xml-originated modules standard IDEA's resources configuration applies.

Eugene.

0

Please sign in to leave a comment.