Project cache - how to clear?

I recently installed the 7041 EAP build. I used it to load a project generated by the Maven idea plugin. Everything worked fine for a while then I got an exception from Idea. Everything seemed to be stuck so, after submitting the exception, I shut down Idea and restarted again. From that point it refused to load the project again. Upon load I'd get an exception message and Idea would continue. When I tried to expand my test sources, it'd go as far as the package with my single test case but show "Loading..." where the class should have been. I could type ctrl-N and type the test class name to get to the class (although Idea didn't offer it as a choice - it just would display the source) but it wasn't recognized as a test.

Thinking that this was a problem with the project, I shut everything down then regenerated it. Same result. Trying to import the Maven pom directly didn't work either (different problem but same result - no functional project).

Next I tried reverting to previous builds. I went back as far as 7002 with the same result: an exception on project load then the "Loading..." message where the class should have been in the UI.

I cleared the VCS caches and system caches. No joy, same thing.

I removed the project from the disk and checked it out again from SVN. Same problem.

I tried manually removing the problem package then adding it again from with Idea's UI. That looked better until I tried to run the test. Idea didn't recognize it as a test. When I shut down Idea and loaded it back up again I got the same "Loading..." problem.

I've just re-generated the project files on a different machine and successfully imported them into 7041, which leaves me perplexed. It leads me to believe that there's some sort of project caching going on that's shared between installations. Can anyone here confirm the existence of such a cache and, if it exists, tell me how to clear the thing?

Thanks
Kevan.

2 comments

I've just re-generated the project files on a different machine and successfully imported them into 7041 ...


sorry if it sounds bold, but maybe check what plugins are installed / enabled.

Ruben

0

I don't have any plugins installed - just a vanilla 7041 install on both machines.

0

Please sign in to leave a comment.