Tomcat 7 deployment problems

Hi

I'm using IntelliJ IDEA Ultimate 12.0.4 and Tomcat 7.0.29

I have a Webapp and have configured Intellij to deploy it to Tomcat. On hitting the Run Tomcat command, Tomcat starts and gets to the point where it says:

INFO: Deploying web application directory C:\tomcat7\apache-tomcat-7.0.29\webapps\manager

This works, but then my app is not deployed. I try telling it to redeploy and I get this message:

Artifact montreal-web:war exploded: Server is not connected. Press 'Deploy' to start deployment.

If I press Deploy, I just get the same message...

Can anyone advise me what I need to do? This used to work...

Andy

4 comments

Hello,

Please provide additional info (new youtrack is probably the best place for this)

1) replace the <IDEA home>/bin/log.xml with the attached one, or add
the following lines at the end of the existing one:
  <category name="#com.intellij.javaee.oss.admin.jmx.JavaeeJmxAdminServerBase">
    <priority value="DEBUG"/> <appender-ref ref="CONSOLE-ALL"/>
  </category>

  <category name="#com.intellij.javaee.oss.util.AbstractConnectorCommand">
    <priority value="DEBUG"/> <appender-ref ref="CONSOLE-ALL"/>
  </category>
2) (re)start the IDEA
3) launch your Tomcat Run configuration and wait until it finishes the startup
4) attach produced IDEA log (Help -> Show Log in ...)
5) attach complete textual content of the Output tab

Regards,
Michael



Attachment(s):
log.xml
0

Thanks. Latest logs attached.

This is the output from the Output tab:

C:\tomcat7\apache-tomcat-7.0.29\bin\catalina.bat run
[2013-03-19 02:16:26,118] Artifact montreal-web:war exploded: Server is not connected. Press 'Deploy' to start deployment.
Using CATALINA_BASE:   "C:\Users\ABell\.IntelliJIdea12\system\tomcat\Unnamed_montreal"
Using CATALINA_HOME:   "C:\tomcat7\apache-tomcat-7.0.29"
Using CATALINA_TMPDIR: "C:\tomcat7\apache-tomcat-7.0.29\temp"
Using JRE_HOME:        "C:\Program Files\Java\jdk1.6.0_33"
Using CLASSPATH:       "C:\tomcat7\apache-tomcat-7.0.29\bin\bootstrap.jar;C:\tomcat7\apache-tomcat-7.0.29\bin\tomcat-juli.jar"
19-Mar-2013 14:16:26 org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.24 using APR version 1.4.6.
19-Mar-2013 14:16:26 org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
19-Mar-2013 14:16:27 org.apache.catalina.core.AprLifecycleListener initializeSSL
INFO: OpenSSL successfully initialized (OpenSSL 1.0.1c 10 May 2012)
19-Mar-2013 14:16:27 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-apr-8091"]
19-Mar-2013 14:16:27 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-apr-8009"]
19-Mar-2013 14:16:27 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 920 ms
19-Mar-2013 14:16:27 org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
19-Mar-2013 14:16:27 org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.29
19-Mar-2013 14:16:27 org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-apr-8091"]
19-Mar-2013 14:16:27 org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-apr-8009"]
19-Mar-2013 14:16:27 org.apache.catalina.startup.Catalina start
INFO: Server startup in 39 ms
19-Mar-2013 14:16:37 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\tomcat7\apache-tomcat-7.0.29\webapps\manager



Attachment(s):
idea.log.1.zip
idea.log.zip
0

Hello,

From the log you've attached I can see you have an issue related to proxy.
Could you try to switch proxy off in IDEA and report here whether it helps?

Regards,
Michael

0

Hi

Thank you - that fixed it.

Also, setting the proxy settings manually rather than leaving IntelliJ on auto detect also worked...

localhost is in my proxy's ignore list, so I'm surprised it went through the proxy at all ??

Andy

0

Please sign in to leave a comment.