7041 keeps locking up under OS X

I've been trying to run build 7041 but it keeps locking up after about an hour of use, but sometimes sooner. My project is huge with thousands of classes. I'm running OS X (10.4.10) and JDK 1.5.0_07-164.

Has anyone else seen this and/or know what the problem might be?

Thanks,

Nick.

4 comments

I just had to kill my Idea process after it having gone catatonic on me.
I think it had run out of memory.
I keep forgetting to adjust memory parameters in info.plist with every new EAP download.
Sounds like you might have tweaked your memory parameters also, given the size of your project.

- T

0

I don't think it ran out of memory as I doubled my heap to 384M. This kind of behaviour makes IDEA unusable and makes me wonder whether it's really a serious contender on the Mac platform. If I can't reliably load large projects then we might have to consider another solution. 5 was better, 6 was worse and 7 has been dreadful so far...

The whole facets thing is a big pain in the arse as well, but that's a separate problem.

0

Well, let's keep in mind that the stuff isn't released yet.
It might be brilliant when it's done. Let's hope so.

0

Having a fine experience here, Spent hours on both a very large and also a smaller project. No problems to report yet. Haven't tried JavaScript editing though.

Also, I did not have to increase the memory allocated in the plist (I always forget too, but this time IDEA did not run out of memory trying to open it and worked fine the entire time I was working).

Keep up the great work.

0

Please sign in to leave a comment.