IDEA doesn't synchronize folder content although I clicked Synchronize

Please check attached image. It happens when I'm trying to add Struts libraries (used Struts facet). I clicked Synchronize button on toolbar of the dialog but it doesn't help. Then I need restart IDEA to help it displays files.

Anyone has same problem?



Attachment(s):
sync.png
5 comments

One more solution (don't need to restart IDEA): Close Project Structure dialog, expand "lib" node in Project tool window, and then come back to add Struts library. It will help to synchronize.

0

I've seen some odd stuff on Synching with 7027 that looks like what you've encountered but I haven't pinned it down enough to file an issue.

0

I've had synchonization issues with external jars, it forced me to revert to #6981, which doesn't have the issue (red classes references are now green) but due to incompatible caches, #6981 must do a full rebuild and crashes with an NPE doing that. Had to revert to M1b...

Gilles

0

On 2007-06-26 23:07:38 +0400, t800t8 <no_reply@jetbrains.com> said:


Please check attached image. It happens when I'm trying to add Struts
libraries. And I need restart IDEA to help it display files.

Anyone has same problem?

<image>


Please watch http://www.jetbrains.net/jira/browse/IDEADEV-18382 to be
notified when issue is fixed.

0

I also noticed that Idea does not pick up updated JAR (I have ant in one
project building jars of a Global Library referenced in other projects).
Sometimes I rebuild the jars while other projects are open. Idea used to
pick the change immediately amd reparse it. Now it does not do it (or not
always). One time it would not even do it after I restarted it. I do not
know what I did but after couple of rebuilds and restarts it finally picked
it up and was ok since then (even picked up following rebuilds immediately).
The only difference is that I keept a source file from jsr's global library
open


"Maxim Shafirov" <max@jetbrains.com> wrote in message
news:f5rlf6$er0$1@is.intellij.net...

On 2007-06-26 23:07:38 +0400, t800t8 <no_reply@jetbrains.com> said:

>
>>
>> Please check attached image. It happens when I'm trying to add Struts
>> libraries. And I need restart IDEA to help it display files.
>>
>> Anyone has same problem?
>>
>> >]]>

Please watch http://www.jetbrains.net/jira/browse/IDEADEV-18382 to be
notified when issue is fixed.



0

Please sign in to leave a comment.