IntelliJ IDEA Ultimate 11.1.5: HTML code formatting indent issue

Hi,

How can I control the HTML formatting? i can't find too much about how it handles idents.

e.g. Take this...

<html><head><body>
<div>code formatting</div>
</body>
</head></html>



Using CTRL+ALT+L, then Run, I get...

<html>
<head>
    <body>
    <div>code formatting</div>
    </body>
</head>
</html>



...But I want to get this...

<html>
    <head>
        <body>
            <div>code formatting</div>
        </body>
    </head>
</html>



How can I achieve this?


Thanks,
Nick
2 comments

Please check Settings / Code Style / HTML / Other tab / "Do not indent children of" option.

Regards,
Alexander.

0

Please sign in to leave a comment.