Evaluating Intellij/IDEA - lagging IDE, what's wrong

I'm evaluating Intellij IDEA (123.169), as I'm considering moving from Eclipse.

However this morning I'm struck with huge delays in the IDE.
I'm on Ubuntu 12.04 using Oracle JDK7.

This shows as the busiest thread:



"ApplicationImpl pooled thread 1" prio=10 tid=0x00007f91445f3000 nid=0x13b6 waiting on condition [0x00007f915cb1c000]
java.lang.Thread.State: TIMED_WAITING (sleeping)
       at java.lang.Thread.sleep(Native Method)
       at com.intellij.util.TimeoutUtil.sleep(TimeoutUtil.java:58)
       at com.intellij.util.io.BaseOutputReader.doRun(BaseOutputReader.java:67)
       at com.intellij.util.io.BaseOutputReader$1.run(BaseOutputReader.java:50)
       at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:465)
       at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
       at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
       at java.util.concurrent.FutureTask.run(FutureTask.java:166)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
       at java.lang.Thread.run(Thread.java:722)
       at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:153)


What could be wrong?


6 comments

Hi Jan,

This stack trace shows that a thread from internal IJ pool is waiting on blocking I/O. Please provide a full dump and your idea.log

Denis

0

The dumps show that EDT is not locked though. Questions:

  1. What commands did you perform when the IDE started to hang?
  2. Are there auto-generated thread dumps?
  3. Please provide your idea.log (Main menu | Help | Reveal log);
  4. Do you have any third-party plugins installed?

Denis

0

1) doing refactoring - moving classes around
2) thread dumps are regularly generated in: ~/.IntellijIdea12/system/logs/threadDumps-[....]-[....]-IU-123.169
3) Uploading (see attachment)
4) Yes, at least two (atlassian JIRA + Eclipse formatter)

Thanks for the quick follow.
I'll keep monitoring this discussion thread closely, hope you can find something.

-Jan.



Attachment(s):
idea.log.zip
0

Unfortunately, the log also doesn't provide a clue.

Am I right assuming that the dumps you provided earlier are from those auto-generated dumps?

Could you try the following:

  • disable that third-party plugins and check if that helps;
  • make a CPU snapshot and provide it for analysis;

Denis

0

I'm not sure whether this is related, but I trashed my IDEA workspace and recreated it.
It's a maven based import. I'm storing the Intellij project/module artifacts outside of the maven project basedirectory.
Initially I had directory based layout (for this multi-module project), now I'm using file-based layout.

Anyway; apparently it did have some effect - as the IDE has picked up speed again. Fingers crossed.
(I'll update this thread when I run into similar issues again).

-J.

0

Please sign in to leave a comment.