problem with idea warning

hi,
i'm using itellij idea 7.0M1b, today when i edit one source file with many warning of redundant typecast, i used F2 to locate warning and using ALTEnter to quick remove redundant typecast, but when i correct the front one, locate next and press altenter, the warning icon doesnt appear till some minutes later, so..so. It's too slow, is it any way to quicker it ? Or is my setting mistaken?

Thanks!

4 comments

You might wanna check the amount of memory that is being used. If that is near the limit than the garbage collector will kick in very often.

one other option might be to create a smaller inspection profile and change to that profile from within the statusbar for large files. Or you can use different scopes and associate specific inspection profiles with it.

HTH

0

one other option might be to create a smaller inspection profile and change to that profile from within the statusbar for large files. Or you can use different scopes and associate specific inspection profiles with it.

but how to create a smaller inspection profile and associate it?

0

create a smaller profile :
Project Settings | Errors | select the inspection profile you're using | create a copy (and saeve it as a project profile) | deselect what you don't need | Apply changes

(first create a scope) :
Project Settings | Scopes | create a scope

associate it with a scope
Errors dialog | select 'Project Profiles' node | Add an entry (you might have to change the default first to enable the add button)

HTH

0

Please sign in to leave a comment.