Project Directory/Drive problem #7002

For some time, I've been developing with IDEA projects with WinXP on a 'subst' drive mapped to a local directory - this allows me to have either the Head or the Branch project directories for our development mapped to the subst drive (J:). It means I can only work on the branch that's currently mapped to that drive letter, but it's very convenient in other respects.

I've just started work on a new project and decided to use a different mapped drive for it. This time, I shared the local project folder and mapped it as a network drive (K:), which is a bit easier to do. When I tried to create a multi-module IDEA project on this mapped network drive, it allowed me to add a couple of modules and then hung, and I had to kill it. I deleted all the IDEA files and tried again with a single module. This time it created the IDEA project and module OK, but when I closed the project and tried to re-open it, I got a message box saying it couldn't find the module file on drive J: (it was looking on the wrong drive). I asked it not to delete the module, but the project opened empty (no module).

I am able to create, open and use an IDEA project directly on the local project folder, but cannot get the same project to open correctly via the mapped network drive (even though all the paths below the project root are relative).

It looks like IDEA has problems working in a network drive mapped to a local folder, but no problem with a subst drive mapped to a local folder.

Confused? I was!

1 comment

OK, the problem was not with IDEA itself - somehow I had an IDEA path variable PROJECT_DIR set to drive J:

Sorry to waste your time.

0

Please sign in to leave a comment.