Android R. being stripped when using smart completion result, how to turn off?

As per the title, say I'm typing:

'textView.setText(R.string.T'

and then smart completion results show up and I choose "TEST", on hitting enter/tab to select the result, the line ends up like this:

'textView.setText(string.TEST)'

is there a way to change this to not drop the R.?

'textView.setText(R.string.TEST)'

I'm adding a lot of R.'s ;)

Build: 123.155
OS X 10.8.2

3 comments

Hmmm that solution is not ideal, I require that setting to be on for 99.9% of my code, it's only R. that I want excluded. This is quite specific to Android, perhaps it can be made a special case related to Android projects? Since R.class has special meaning in human terms (despite just being a simple list of int references).

0

It is something we should think about. I've created another issue about this, please follow

0

Please sign in to leave a comment.