How can I choose which class version to use when debugging?

I have Idea project where several modules are open. Inside I have several versions of some lib which classes I need to debug. Several versions exists because some of the are used in other applications, open in my project, or may be in the same application I use two versions of one library. The question is: how can I choose which version of my class is shown while debugging the code? It looks like Idea chooses the version of lib just in the order they are placed in the workplace. I have deleted some lib's version from my project and I went on debugging with another version. Idea cannot grasp the version number I REALLY use in my code.

So the question is : how can I say to Idea which lib to use while debugging?

1 comment

Hi Dmitry,

That's is controlled via defining a module which classpath should be used during target run configuration's execution:

classpath.png

Denis

0

Please sign in to leave a comment.