Tomcat server to not response

Hello.

I trying to make this simple lesson: http://wiki.jetbrains.net/intellij/Creating_a_simple_Web_application_and_deploying_it_to_Tomcat

I have install Tomcat 7 by Homebrew (for Mac OS X Mountain Lion).
I have Intelij Idea 12

Following this lesson I created empty project, added dir to Tomcat7 installation (Idea got it).

In documentation I see: in the Project tool window, right-click index.jsp and choose Run index.jsp on the context menu. IntelliJ IDEA creates a temporary run configuration index.jsp on the fly and launches the application.

I tryed to right-click on index.jsp and do not see "Run index.jsp" element.

...

When I tryed to run project by menu "Run => ..." all menu elements are disabled. Only "Edit configurations" enabled. I open it, create new configuration and select all like in this screenshot:

https://api.monosnap.com/image/download?id=Rvrz9t9TjrnohlqJMghnzfjQw

And when I run project I see in output panel this
> /usr/local/Cellar/tomcat/7.0.35/libexec/bin/catalina.sh run

There are no messages about error.

When I open http://localhost:8080, browser says that "Server not found".

When I stop it and run by console:
> catalina run

default Tomcat server runs OK.

Can you help?

2 comments

Fixed it with configuring artifact building.

But index.jsp still cannot be opened by context menu.

0

But index.jsp still cannot be opened by context menu.


Thanks for a catch,
Lost "Run index.jsp" menu item is a regression, will be fixed for 12.1 EAP's and next 12.0.x if there will be one.

Regards,
Michael
0

Please sign in to leave a comment.