ubuntu 11.10 compiz showing 20% cpu all the time

I have a pretty decent core i7 740 machine for development. It is usually hanging around  2 or 3% cpu usage in idle. But after I start Intellij - even with an almost empty project (just a couple of hand written classes), compiz shoots up to 20% - and stays there indefinitely.  

I noticed this problem because i would be doing something else and notice that the fan would come on - even though my laptop was not really doing much. Then on "top" I see compiz 20%.  After shutting down other programs it was isolated to IJ (using 11 ultimate).   This is repeatable: i have shut down machine, then watched "top" (2-3%) then started IJ (and waited for it to stabilize).  Minutes later it's still at 20%   - even though there is no work being done (e.g. indedxing). Again: this is an almost empty project so almost zero indexing was required anyways)

10 comments
Comment actions Permalink

Anyone else seeing this? Better yet, found an explanation if not a solution?  
thx
0
Comment actions Permalink

Hello,

Ubuntu 11.04, everything is fine.

Denis

0
Comment actions Permalink

Well i'm not sure how I am supposed to react to that answer.  I'm not using 11.04, I'm using 11.10. And things are not fine in 11.10.    20% cpu for a tiny project even when I am not even interacting with IJ?  And it is repeatable across system reboots.

I did not see this problem in ubuntu 10.04 either - but then what, am I supposed to revert to earlier version of ubuntu just to make Intellij happy?

0
Comment actions Permalink

Sorry but you asked whether other intellij gnome users experience the problem. You can just ignore my reply if 11.04 is irrelevant for you.

Regarding the problem - I agree that such a situation is definitely bad but from what you've said it looks more like 11.10/compiz/java problem than IJ. I'm afraid it's not worth from our side to spend development resources for investigating native/jre processing in this particular environment.

Denis

0
Comment actions Permalink

Maybe looking into this issue could help some: http://youtrack.jetbrains.net/issue/IDEA-76946

0
Comment actions Permalink

I get into this same state: compiz was taking 30% of cpu last night and my desktop was essentially no-respondent:  Opened a console terminal (Ctrl-Alt-F2) see what htop had for me.  When I kill IntelliJ, compiz went back to baseline.  Seems pretty clear there's an interaction there

This has been happening to me on SuSE114 (gnome2) and Ubuntu-11.10(gnome3/unity)

As such one has to suspect JetBrains as the common denominator.  Certainly worth JetBrains seriously  investigate.


JDK7 is a side-step of the issuem imo.

0
Comment actions Permalink

I got exactly the same problem with Ubuntu 12.04 (compiz showing 20% cpu all the time).

I solved it by switching to Oracle JDK 1.7.0_04 and setting -Dsun.java2d.xrender=true in idea64.vmoptions. Since IntelliJ IDEA 11.1.2 (build IU-117.418) the problems with XRender and the editor not displaying correctly have been solved, so IntelliJ IDEA is usable now with the XRender pipeline. And as a bonus you get better subpixel font aliasing. :)

Note however when using JDK 1.7 there are some other issues with dual screen configuration (IDEA-86850, IDEA-86392), but this is a different story.

Hope this helps,
Dirk.

0
Comment actions Permalink

Thanks Dirk, i have marked your answer as helpful.  In my case am stuck with jdk6 because of hadoop work and the versions I am using do not support jdk7.

However, in general I have seen this issue disappear with IJ12: it is great for performance.

0
Comment actions Permalink

Hi Stephen,

As far as I see you said that you need to use java6 for projects which you participate in but you can run IJ itself under java7 (gives an ability to use xrender). I.e. run IJ under java7 but use java6 for projects compilation/running.

Denis

0
Comment actions Permalink

thanks Denis, in any case i see great performance in IJ12.  kudos.

0

Please sign in to leave a comment.