Code showing all references to ecternal classes as missing but build works okay

So I had a striaghtforward single module java project working fine with Intellij Jetbrainz 12.0.1 no problem.
Then today it showed any reference to a class in an external jar in red as if it couldnt be found, although Build/Rebuild Project still worked without any errors.
I fiddled around with the dependencies, recreated the project from scratch, and then upgraded to 12.0.2 but still no improvement.

I recreated from scratch again
I have all my external jars in a single folder, and I add that folder to Modules/Dependencies
Without adding it build fails, if i add it the build is fine, but I still get every reference to these classes marked as red

Is something corrupt, how would I reset my default settings

Comment actions Permalink

Please try File | Invalidate Caches -- it usually helps when such random weird bugs appear out of nowhere (especially after upgrading).

Comment actions Permalink

Thansk that did the job


Please sign in to leave a comment.