Breakpoints not breaking in external sources

I am using the latest version of Intellij 12 with a Grails 2.2 project. I have been walking through the Grails code debugging a plugin that I am working on. The Grails source is defined (correctly) automatically by Intellij when the SDK is created. This has worked fine until today. Breakpoints set in the the Grails source do not break. Breakpoints set in my source do. I have tried recreating the project form source. I have tried changing the SDK. I have tried clearing out .grails and doing all of these things at the same time, but I cannot get Intellij to recognize the breakpoint in the external source, anywhere in the external source.

I'm not sure what, if anything, I would have set to change this behavior. Either way, I recreated the project and grails environment and still cannot get those breakpoints to hit. I suppose I could try downloading the source separately and modifying the SDK to point to source that is not jarred up. But that seems like a lot of effort that I shouldn't have to go through for a fairly basic feature -- and I'm not sure it would do any good.

Any suggestions would be appreciated!

Thanks,

Jon DeJong

2 comments

UPDATE: Breakpoints are breaking in the Grails source -- just not all the time. My simple cases are working fine. There's a case where a closure is 'causing a breakpoint to not get hit. The simple example is, in a controller, calling something like:

render myObject as JSON

This should and (it appears) eventually does execute RenderDynamicMethod.ivoke(), but the breakpoint in that method will never break.

0

Do you use maven in the Grails project? What is your OS?

0

Please sign in to leave a comment.