Turn off all Code Folding

Hopefully easy one.  How to do this?  I already have unchecked all boxes in teh project settings  | code folding | fold by default.

Still code folding is happening pretty frequently.

is there another 'master' switch somewhere?

4 comments

No, there is no other setting. Can you provide more information on what code is being folded even when all folding settings are off?

Denis

0

Hi Denis,

Every time that I go out of an editor tab, (having already manually unfolded the code - e.g. all method and class headers are getting collapsed!).  When I go back in teh same file they are collapsed again!

This really needs to be fixed !

This is scala code.

0

That's a known problem of our Scala plugin - SCL-4833. Feel free to vote it up and track the progress.

Denis

0

Thank Denis for closing the loop on this, yes I really hope this is fixed soon, and I have voted it up.

stephenb

0

Please sign in to leave a comment.