calling External Tools - $ModuleFileDir$

When creating an entry for calling an External Tool
the Working Directory text-entry-field is set to : $ModuleFileDir$

In IDEA 6.x this corresponded to the directory of the actual module,
in build 6819 (running on Win XP sp2, jdk1.5_06)
it always complains about:

Error running package: Cannot start process, the working directory c:\intell~1.0m1\bin
does not exist.
Which is true, it does not exist, Selena is installed in c:\IntelliJIDEA7.0M1.
However this is not the $ModuleFileDir$.

HTH

2 comments

Hello Patrick,

Please, make sure that when you start the tool IDEA can understand what module
is current.
E.g. if cursor is in console view, IDEA cannot defne this properly and shows
message you report about.
If I put cursor into a java file which belongs to some module, IDEA understands
what this module is.

When creating an entry for calling an External Tool the Working
Directory text-entry-field is set to : $ModuleFileDir$

In IDEA 6.x this corresponded to the directory of the actual module,
in build 6819 (running on Win XP sp2, jdk1.5_06)
it always complains about:
Error running package: Cannot start process, the working directory
c:\intell~1.0m1\bin
does not exist.
Which is true, it does not exist, Selena is installed in
c:\IntelliJIDEA7.0M1.
However this is not the $ModuleFileDir$.

HTH

Alexander.


0

Yes, you are correct.
When the Run-window is active/opened it does not work, otherwise it works fine.

I noticed this, but was "too late" to close this incident.
thx

0

Please sign in to leave a comment.