i have error "exit code is 1" what happen?

im use win 7 64bit, my editor is intellij idea 3

i get log like this:

Information: 1 error

Information: 0 warnings

Information: java.lang.ClassNotFoundException: -verbose

Information:     at java.lang.Class.forName0(Native Method)

Information:     at java.lang.Class.forName(Class.java:140)

Information:     at com.intellij.rt.compiler.JavacRunner.main(JavacRunner.java:24)

Information: Exception in thread "main"

Error:  line (0) The compiler did not terminate normally. Exit code is 1

what i must to do for fix it,

nead help :(

6 comments
Comment actions Permalink

denielmunthe wrote:
im use win 7 64bit, my editor is intellij idea 3

Are you really using version 3? That is 9 or 10 years old at this point. What version of Java are you compiling against? I suspect version 3 is not compatible with Java 6 or 7; maybe not even Java 5. You are most likely going to need to update to a newer version of IntelliJ IDEA. When do you get this error?

0
Comment actions Permalink

there are cases where a previous program runs in 3 and j2sdk1.4 intellij idea, and I was previously using intellij idea 11, 
but the program is error, what should I set it to run in intellij 11, and if I'm still using the 3 series what action I need to do?

help

0
Comment actions Permalink

If the program runs in IntelliJ version 3, it should certainly run in IntelliJ 11. If it is a Java 1.4 based program, you can either configure IntelliJ 11 with a 1.4 JDK:

  1. Add the SDK in the Project Structure ( Files > Project Structure). On the left side in the Platform Settings" section, select "SDKs".  Use the "+" icon to add a JDK
  2. After doing that, in the same "Project Structure" dialog, select "Project" in the "Project Settings" section. Change the "Project SDK" to the SDK you just created. And set the "Project language level" to 1.4
  3. Next select "Modules" in the "Project Settings" section. Select each module in your project. Select the "Sources: tab and make sure the language level is set to "<Use Project language level>" (or to 1.4). Then select the "Dependencies" tab on the right. Make sure the "Module SDK" (towards the top) is set to "Project SDK (<name of your SDK>).


You do not necessarily have to use a 1.4 JDK. All newer JDK's are backwards compatible. So you can use a Java 7 JDK. By setting the language level options in IntelliJ, it will pas "1.4" values to the compiler for the -source and -target options.

Your original post said the error was in the log. Do you mean the IntelliJ IDEA log? If so, make sure you are using Java 6 or Java 7 to run IntelliJ version 11 (not Java 1.4 or 5). You can set the environment variable IDEA_JDK to the path to a Java 6 or 7 JDK or JRE install. See this post for information on the search order IntelliJ IDEA uses to determine what JDK to use when running. Do not confuse to the version of Java that IntelliJ IDEA uses to run with the version your project uses. You can run IntelliJ with Java 6 and write a Java 4, Java 5 or even a Java 7 project.

If this does not solve your problem, can you provide more detail. When are you getting this error message? When trying to run the program in IntelliJ IDEA? When trying to start IntelliJ IDEA?

0
Comment actions Permalink

thank you for the advice, I've run it with intellij idea 11, and running.
whether all of these actions can be done to all project a different level?


thanks before :D

0
Comment actions Permalink

I am not sure that I completely understand your question. But if I think this will answer it. If not let me know.

  • Different projects can use different JDKs and different language levels.
  • Different modules within a project can use different JDKs and different language levels.
  • You can, set default values for new projects. When you create a new project the defaults are used. To do this:
    • In IDEA 11 go to File > Other Settings > Template Project Structure. Set what you want ot be defaults.
    • In IDEA 12, the menu name been changed from "Template Project Structure" to "Default Project Structure"


I hope that answers your question. If not let me know.

0
Comment actions Permalink

the answer you have answered my question, thank you for your help

best regards

Deniel M

0

Please sign in to leave a comment.