Unable to compile Java8 file in IDEA12

I'm trying to compile some sample Java 8 code, but I'm getting this error:


java: lambda expressions are not supported in -source 1.8
  (use -source 8 or higher to enable lambda expressions)


I've set the Project SDK to 1.8 (java v3ersion "1.0.0-ea") and the Project language level to "8.0 - Lambda, type annotations etc." in the Project Structure settings.  What am I doing wrong?

1 comment
Comment actions Permalink

Please download jdk build with lambda support enabled from http://jdk8.java.net/lambda/

0

Please sign in to leave a comment.