Whitespace not being stripped?

I have webstorm set to strip all whitespace, but it doesn't seem to be working at all on save.

The issue is only on blank lines and it seems to be inserting a tab (I do not have this set in the codestyle settings).

Am I missing something?

3 comments
Comment actions Permalink

Do you have 'Keep indents on empty lines' enabled in your code style preferences? Also, are you using .editorconfig by chance? Try disabling EditorConfig support in Preferences >Editor > Code Style by unchecking 'Enable Editorconfig support' checkbox - does it help?

0
Comment actions Permalink

Also, can you check if the problem can be recreated in 2016.2 EAP? May be related to https://youtrack.jetbrains.com/issue/IDEA-156530 that was fixed there

0
Comment actions Permalink

Hi Elena, I do not have 'keep indents on empty lines checked'. I also disabled EditorConfig, it didn't appear to do anything. Is the expected behavior for it to remove any spaces left on empty lines on a save?

I will check the EAP and report back.

0

Please sign in to leave a comment.