IntelliJ 11 slow on Mountain Lion

Hi,

I just upgraded my mac to MountainLion and everything works so far - except IntelliJ is now so slow, that working is a pain. Every time the window gets Focus, I'm getting the beachball. This was not happening with Lion...
Any suggestions what might fix that?
I tried updates, different JDK-Versions and so on - nothing helped! Suggestions more than welcome!

Regards,

Stephan

15 comments
Comment actions Permalink

Please try if Settings->General "Synchronize files on frame activation" influences this.

0
Comment actions Permalink

Yes, it does as expected. Thanks, this is a good way.

But why does this bother me now? With Lion this setting was fine ...

And now I have to hit the "refresh" button manually - which again causes IntelliJ to freeze for a couple of seconds. This is quite annoying...

0
Comment actions Permalink

Please try the advices given in http://devnet.jetbrains.net/docs/DOC-192

I do not experience the same problem after switching to Mountain Lion, so I suspect it might be something specific to your system. Did you change any hardware, filesystem, ..? Did you update 3rd party drivers?

0
Comment actions Permalink

No, I just upgraded with the default installer. Some Apps I needed to delete, as they are not supported anymore (parallels for example), had to install the JDK manually, but I thought it worked now.

I probably need to mention that my MacBook does have an SSD drive, so file access should be fast. But hitting the refresh button brings up the BeachBall since the upgrade...

0
Comment actions Permalink

Same problem happening to me on a new MBP retina with Mountain Lion.
Window freezes when you try to open a new file.
Seems worse with some files (eg xml)
Seems to be ok with files that have already been opened.

Freezing stopped when frame activation setting changed as above (but now I have to manually sync, no?).

Currently running Lead with 2gb ram (out of 16gb), and java/groovy compilation in a separate process.

Current performance would make IJ unusable, fyi.

David

0
Comment actions Permalink

I have the same machine (MBPr) and IJ flies. I would also suspect 3rd party software.

0
Comment actions Permalink

I don't know if that was the reasone, but I had some issues with Mail.app. In the console there were a whole bunch of messages like "Cannot access /Library/Application...." I don't remember

I removed that file (some plist) and now everything works find.

Seems like, Mail produced a lot of IO-Load causing IntelliJ to "freeze"...

0
Comment actions Permalink

Have you had any luck with this issue? I'm experiencing the same thing in PHPStorm 5. It seems to have started for me after updating to PHPStorm 5. Everything else is still stupidly fast on my SSDs. Starting PHPStorm 5 from scratch comes up in < 5s with 10-20 files open, while opening a single file from any dialog (open, navigate to class/file/symbol, etc) takes over 90s!

0
Comment actions Permalink

Please try disabling any 3rd-party plugins.

0
Comment actions Permalink

Thanks for that advice. Disabling IdeaVim seems to have resolved it. That puts a huge crimp in my development though as my fingers are pretty vim trained at this point. I've filed a bug with the IdeaVim, I guess we'll see if they have any thoughts.

0
Comment actions Permalink

So I deactivated all 3rd party plugins, and I still get a 5 second 'freeze' when clicking on a previously unopened file.
ie: Leda seems to take 5 seconds to open a new file for the first time.
I don't think I should be seeing this on a 2012 macbookpro retina with 16Gb ram..

0
Comment actions Permalink

After struggling with this issue for another month, and after being forced to go back to Eclipse (gasp!), I decided to try and fix this again.

This time I had some success, using these steps:

1) disabled all of the plugins that I wasn't using, including bundled plugins.
2) disabled all file synchronization, frame deactivation, etc.
3) disabled auto building (this one is my top suspect).
4) doubled all the memory settings in Info.plist (I have 16 GB ram, and use JDK 1.7 64 bit).
5) Invalidated the caches.

So, now the problem resolved, albeit at the expense of some functionality.

At some point I'll start to reactivating the plugins, and settings, and will report back when I find the culprit.

For those who have experienced this problem, a 20 second delay on each new file essentially makes the IntelliJ unusable.

0
Comment actions Permalink

I found that this issue was due to something with the VIM plugin. You could disable the vim plugin, or disable the Retina support for PHPStorm (which is what I've fallen back to, especially since I tend to use PHPStorm on an external monitor 90% of the time) You can remove retina support for a single app by doing a Get Info on it and checking the 'Open in low-resolution' checkbox. It's not ideal, but there is a bug open for it on the Vim plugin tracker.

0
Comment actions Permalink

Thanks Seth, but I don't use VIM (or PHPStorm).

Dave

0
Comment actions Permalink

the bug isn't PHPStorm specific, it applies to anything on the platform. Have you tried turning off the retina support for IntelliJ?

0

Please sign in to leave a comment.