IntelliJ 11.1.3 loosing packages, making up new (unnamed) ones...

Hi All,

Recently I switched from a Windows XP to a Windows 7 installation and after reinstalling IntelliJ importing my projects everything is screwed...

Nothing compiles in IntelliJ, using Maven 3 everything is fine. IntelliJ also makes up new (unnamed) packages, directories and projects... Basically everything is borked... Tried a new project, thrown away everything, fresh imports but the problem remains or happens again.

This images displays the problem...


I'm open to ideas suggestion to fix this as it is becoming quite irritating....

Comment actions Permalink

Uh, that looks really scary.

Did you try, "File -> Invalidate Caches"? This will help, if you have some accidental corruption.

If it doesn't help, please create a bug report here: (you can use your forum account to login) and attach your logs (USERPROFILE\.IntelliJIdeaXX\system\log on Win/Linux or ~/Library/Logs/IntelliJIDEAXX on Mac).

Comment actions Permalink

Thanks for the answer. It seems related to the fact where I place the idea project files. I created a new project and placed the idea project files in the same directory as the project sources and now it works without a problem. The situation I had was that I had my files in a different directory and for some reason it then goes haywire....


Please sign in to leave a comment.